Web app slowdown EU

Resolved
Duration: 9h 53mJul 6, 2026

Affected services

web platform

Degraded

Timeline

Resolved
07:11Jul 7, 20269d ago

We have resolved the incident.

Monitoring
22:14Jul 6, 20269d ago

We have fixed the issue and are monitoring the affected services.

Identified
21:42Jul 6, 20269d ago

We have identified the root cause for this incident and are fixing it.

Monitoring
21:25Jul 6, 20269d ago

We have fixed the issue and are monitoring the affected services.

Identified
21:22Jul 6, 20269d ago

We have identified that the current degradation affecting our web platform is caused by an issue on Cloudflare's end. Our team is actively monitoring the situation. We will continue to provide updates as the situation progresses.

Investigating
21:17Jul 6, 20269d ago

We are currently investigating this issue.

web platform