EU import service experiencing instability affecting data processing and user operations

Resolved
Duration: 1h 27mJun 2, 2026

Affected services

web platform

Degraded

core services

Degraded

Timeline

Resolved
11:32Jun 2, 20269d ago

We have resolved the incident.

web platformcore services
Monitoring
10:49Jun 2, 202610d ago

we have fixed the issue and currently monitoring it

web platformcore services
Investigating
10:05Jun 2, 202610d ago

We are currently investigating instability affecting our EU import operations. This is impacting the import functionality and data processing workflows in the European region. Our teams are actively working to identify the root cause and restore normal service levels. We will provide updates as we learn more.

web platformcore services