EU server services unavailable

Resolved
Duration: 2h 24mJan 29, 2026

Affected services

web platform

Major outage

geo services

Major outage

core services

Major outage

Timeline

Resolved
15:33Jan 29, 20267mo ago

We have resolved the incident.

Monitoring
13:14Jan 29, 20267mo ago

We have fixed the issue and are monitoring the affected services.

Investigating
13:08Jan 29, 20267mo ago

We are currently investigating this issue.

web platformgeo servicescore services