US servers latency

  • Now
  • Jan 12, 2026, 5:13:23 PM UTC
    Resolved

    We have resolved the incident.

  • Jan 12, 2026, 4:50:18 PM UTC
    Monitoring

    We are currently investigating this issue.

    core services