DNS provider issue

  • Now
  • Nov 18, 2025, 3:14:53 PM UTC
    Resolved

    We have resolved the incident.

  • Nov 18, 2025, 1:11:00 PM UTC
    Identified

    CLOUDFLARE : The issue has been identified and a fix is being implemented.

  • Nov 18, 2025, 1:03:01 PM UTC
    Investigating

    Cloudflare is continuing to investigate this issue.

  • Nov 18, 2025, 12:31:50 PM UTC
    Monitoring

    Cloudflare services seems UP

  • Nov 18, 2025, 12:30:01 PM UTC
    Investigating

    Cloudflare is seeing services recover, but customers may continue to observe higher-than-normal error rates as we continue remediation efforts

  • Nov 18, 2025, 12:14:47 PM UTC
    Monitoring

    Cloudflare services seems UP

  • Nov 18, 2025, 12:10:32 PM UTC
    Identified

    Cloudflare is aware of, and investigating an issue which impacts multiple customers: Widespread 500 errors, Cloudflare Dashboard and API also failing. They are working to understand the full impact and mitigate this problem. More updates to follow shortly

  • Nov 18, 2025, 11:51:29 AM UTC
    Identified

    Cloudflare Global Network experiencing issues

  • Nov 18, 2025, 11:50:51 AM UTC
    Investigating

    Major issue on Cloudflare https://www.cloudflarestatus.com/?t=1

    web platform