false alert on "payment failed"

  • Now
  • Sep 24, 2025, 9:09:31 PM UTC
    Resolved

    We have resolved the issue

  • Sep 24, 2025, 9:09:13 PM UTC
    Monitoring

    We have fixed the issue and are monitoring the affectd services

  • Sep 24, 2025, 9:02:21 PM UTC
    Identified

    we are managing with our billing provider

  • Sep 24, 2025, 8:49:52 PM UTC
    Investigating

    We are currently investigating this issue.

    web platform